On this page:
3.2.1 Coreform Cubit™ Application Window
3.2.2 Command Panels
3.2.2.1 Command Panel Functionality
3.2.3 Drop Down Menus
3.2.4 Options Menu
3.2.5 Undo Button
3.2.5.1 Limitations
3.2.6 Graphics Window
3.2.6.1 Viewing Curve Valence
3.2.6.2 Selecting Entities in the GUI
3.2.6.3 Key Press Commands for the GUI
3.2.6.4 Right Click Commands for the GUI Graphics Window
3.2.6.5 View Navigation in the GUI
3.2.7 Tree View
3.2.7.1 Model Tree
3.2.7.2 Power Tools
3.2.7.3 Geometry Power Tools
3.2.7.4 Meshing Tools
3.2.7.5 Mesh Quality Tools
3.2.8 Command Line Workspace
3.2.9 Journal File Editor
3.2.10 Property Page
3.2.11 Toolbars
2022.4+26187-e1209cf7 Apr 14, 2022

3.2 Graphical User Interface

The graphical user interface (GUI) can improve user productivity. It provides an easy way to control Cubit without learning command syntax. Many geometry commands are faster and easier with the GUI. The underlying GUI components are constructed using a cross-platform development environment. As such, the GUI will behave similarly across all platforms supported by Cubit, yet each GUI will make use of platform specific widgets. The GUI is built on top of the Cubit command line. This means that GUI actions are translated to a Cubit command-line string and journaled. Users familiar with command-line syntax can enter the same text in the GUI command-line window. Journal files can be created and played back in both environments with the same results. Although many things are faster and easier in the GUI, experienced users often use a combination of command line text and GUI button operations. The discussion of the Graphical User Interface and its features is based on the basic windows contained within the Cubit GUI Application Window. These are outlined in the subtopics listed above.

3.2.1 Coreform Cubit™ Application Window

The default Coreform Cubit Application Window is shown in the following image.

Figure 12: The Coreform Cubit Application Window

Graphics Window- The current model will be displayed here. Graphical picking and view transformations are done here.

Model Tree - Tree view of the models components, including geometry, materials, boundary conditions, and so forth.

Power Tools - Geometry analysis and repair tool, meshing tool, meshing quality tool, and ITEM Wizard.

Property Editor - The Property Editor lists attributes of the current entity selection. Most of these properties can be edited from the window.

Command Panel - Most Cubit commands are available through the command panels.

Command Line Workspace - The command line workspace contains both the Cubit command and error windows. The command window is used to enter Cubit commands and view the output. The error window is used to view Cubit errors.

Drop Down Menus - Standard file operations, Cubit setup and defaults, display modes, and other functionality is available in the pull-down menus.

Toolbars - The most commonly used features are available by clicking toolbar icons.

3.2.1.1 Context Sensitive Help in the GUI

The Graphical User Interface has a context-sensitive help system. To obtain help using a specific window or control panel, press F1 when the focus is in the desired window. It may be necessary to click inside a text box to switch focus to a particular window. If no context specific help is available, it will open the Cubit help documentation where you can search for a particular topic.

3.2.1.2 Customizing the Application Window

All windows in the Cubit Application can be Floated or Docked. In the default configuration, all windows are docked. When a window is docked the user can click on the area indicated below.

Figure 13: A docked window. Click and drag to float.

By dragging with the left mouse button held down, the window will be un-docked from the Application Window. Dragging the window to another location on the Application Window and releasing the mouse button will cause it to dock again in a new location. The bounding box of the window will automatically change to fit the dimensions of the window as it is dragged. Releasing the mouse button while the window is not near an edge will cause the window to Float. To stop the window from automatically docking, hold the CONTROL key down while dragging.

Figure 14: A Floating Window

When a window is floating, as shown in Figure 14, it is possible to dock it by clicking the title bar of the window and dragging it to its new docked location.

Double clicking on the title bar of an floating window will cause the window to redock in its last docked position.

3.2.2 Command Panels

The Command Panels provide a graphical means of accessing almost all of the Cubit functionality. The main Cubit Command Panel is divided into six modes. Each of these modes pertains to a major component of the Cubit application. To view information about each of the tools in the Control Panel select the help icon on each panel to access context specific help. From left-to-right, the command panel modes are:
  • Geometry Operations

  • Meshing Operations

  • Analysis Groups and Materials Operations

  • FEA Boundary Condition Operations

  • CFD Boundary Condition Operations

  • Post-meshing Launch Control

Figure 15: The Cubit Control Panel

A brief description of the functionality of the Control Panel window follows.

3.2.2.1 Command Panel Functionality

Use Tools/Options/Command Panels to control these options.

The Command Panel navigation hierarchy can be used in several different ways:

Figure 16:

  1. The Classic look includes rows of buttons with icons. The hierarchy is entity-based. Geometric, mesh, and other entity types are the focus of the hierarchy. A user navigates entity types then selects actions to perform on those entities.

  2. The default hierarchy is action-based. Actions such as create, modify, delete, mesh sizing, mesh, boolean, and so forth are the focus of the hierarchy. A user navigates to the action to be performed then selects an entity type on which to perform the action.

  3. Breadcrumb navigation is new in Cubit 2020.2. The breadcrumb navigation method will use the hierarchy chosen by the user but will present the options in a much more concise manner, freeing up valuable vertical space in the UI. The figures below show the Breadcrumb navigation method.

Figure 17:

Figure 18:

The Command Panel is arranged first by mode on the top row of buttons. Modes are arranged by task. All of the geometry related tasks, for instance, can be found under the Geometry mode. When a mode is selected, a second row of buttons becomes available, then a third. The second row of buttons shown depends on the selected mode.

Below is the command panel showing Geometry. Notice the second row shows actions, such as create, modify, transform, boolean, decomposing, and so forth. The third row shows geometry types. This hierarchy implies many geometry operation types are applicable to most entity types.

Figure 19:

Below is the command panel showing Mesh. Here, the second row shows the various entity types. The third row shows operations that can be performed on those entity types. This hierarchy implies mesh operations tends to be more specific (when compared to geometry operations) to a given mesh entity.

Figure 20:

In all cases, regardless of the button hierarchy, the user will finally be presented with a command panel. Shown is the command panel for creating lofted volume.

Figure 21:

All command panels are constructed similarly. Each panel represents one or more Cubit commands. Options are selected using check boxes, radio buttons, combo boxes, edit fields, and other standard GUI widgets. Each command panel includes an Apply button. Pressing the Apply button will generate a command to Cubit. Nothing happens until and unless the Apply button is pressed.

The edit fields are free form, which means the user may enter any valid string into the fields. Any string that is valid for the command line is valid for the command panel edit fields.

3.2.3 Drop Down Menus

The Cubit Drop-Down Menus, located at the top of the Cubit Application Window provide access to capabilities such as file management, checkpoints, display manipulation, journaling, system setup, component management, window management, and help.

3.2.3.1 Cubit (Mac Only)

This menu contains the Preferences dialog box, also called the Options dialog box on other platforms. It also contains the About Cubit menu and the Quit Cubit option. It is only available on Mac computers.

3.2.3.2 File

This menu provides common file operations, including importing and exporting of geometry and meshimport and export. A list of recently saved or imported files is also provided, allowing a quick way to import current or recent work. Non-Mac users can also exit and reset the program from this menu (These options are found under the Cubit tab for Mac Users).

3.2.3.3 Edit

This menu only provides a way to enable the Undo feature of the system. If Undo is enabled, one level of Undo is available to the user.

3.2.3.4 View

The View Menu lists all available toolbars and windows in the current Cubit session. Selecting a toolbar or window will make it visible. Deselecting a toolbar or window will hide it. You can also hide an undocked window or toolbar by clicking on the small "x" in the upper right corner. For more information on docking and undocking toolbars, see Cubit Application Window.}

3.2.3.5 Display

The Display Menu controls display options for the graphics window. These options are explained below:
  • View Point - Controls the camera view point. Choices are front, back, top, bottom, right, left and isometric views.

  • Render Mode - Controls visibility modes, including: wireframe, true hidden, hidden line, transparent, and shaded.

  • Geometry - Controls geometry visibility

  • Mesh - Controls mesh visibility

  • Graphics Composite - Controls the visibility of composited entities in the graphics window.

  • Refresh - Updates the graphics display

  • Background - Changes the background color

  • Zoom In - Enlarges the model in graphics window

  • Zoom Out -Shrinks the model in graphics window

  • Zoom To Fit - Enlarges or shrinks model in the graphics window so it fills the whole screen

  • Toggle Perspective - When this option is selected, the entities in the graphics display window are drawn in perspective mode.

  • Toggle Scale - Turns on or off a graphical scale that can be drawn in the graphics window to obtain a bearing on model or part sizes.

  • Toggle Clipping Plane - Turns on or off the graphics clipping plane

  • Toggle Clipping Plane Manipulation - Turns on or off manipulation of the graphics clipping plane

  • Show Curve Valence - Turns on or off the curve valence highlighting

3.2.3.6 Tools

The Tools Menu contains access to GUI-specific tools and options. These options are explained below.
  • Journal Editor - Opens journal file editor. The Journal Editor is used to write, edit, play, and save journal files. It can also be used to create and edit Python scripts. A built-in translator will convert between the two files types.

  • Play Journal File - Plays a specified journal file. You can browse through files and folders on your computer to select the journal file to play.

  • Options - Opens the Option dialog box. This dialog box controls all of the preferences for the GUI including display colors and widths, mouse settings, journal file options, mesh and geometry defaults, and general layout preferences. MAC users can find this menu under the Cubit tab.

  • Components - Opens the Components dialog box. This window is used to load and unload external and internal components.

3.2.3.7 Help
3.2.4 Options Menu

To change program preferences in the Graphical User Interface select: Tools > Options .

Mac users reach this dialog box by selecting the Cubit > Preferences menu.

3.2.4.1 Command Panels

This menu controls certain behaviors on all command panels.

3.2.4.2 Display Preferences

This menu controls entity display features for the graphics window which include the following:

3.2.4.3 General Preferences

This menu controls general program options including the following:

3.2.4.4 Geometry Defaults

This menu controls the geometry defaults.

The user can also change the default geometry engine to one of the following:

The faceting tolerance can also be controlled from this menu to change the way facets are drawn in the graphics window. The default file format may be set.

Mesh Auto Delete

3.2.4.5 History Preferences

This menu controls the input window history and journal file options. These include:

3.2.4.5.1 Cubit History Preferences
3.2.4.6 Label Defaults

This menu controls the geometry and mesh entity labels in the graphics window.

3.2.4.7 Layout Preferences

This menu option controls input window formatting and control panel docking options.

Also included in the layout preferences is a list of available windows with a checkbox to show/hide each window.

3.2.4.7.1 Cubit Layout Settings

This menu controls the layout of Cubit specific buttons and tabs on the GUI.

3.2.4.8 Mesh Defaults
3.2.4.9 Mouse Settings

This menu controls mouse button controls. Pressing the Emulate Command Line Settings button will cause all of the settings to simulate mouse controls in the command line version of Cubit. For a detailed description of mouse settings see the View Navigation-GUI page.

3.2.4.10 Post Meshing Settings

Control the behavior of the Post-Meshing button. The button is located at the right-hand side of the top-level command panel button bar.

Figure 22:

The very first time a user presses the button, the Post-Meshing Settings dialog will be displayed.

Figure 23:

The dialog includes three possible inputs:

3.2.4.11 Quality Defaults

This menu controls quality defaults for different quality metrics. For a description of the different quality metrics see the respective pages:

3.2.5 Undo Button

Cubit has an undo capability. To enable the Undo feature click on the Enable Undo button on the Toolbar.

Figure 24:

With undo enabled, click the undo button to reverse operations.

Figure 25:

Alternatively to turn undo on and off, the following command may be used in the command line:

undo {on|off}

The Undo capability is implemented for geometry and some meshing commands including webcutting, geometry creation, transformations, and booleans. The commands will be undone in reverse order of their execution.

3.2.5.1 Limitations
3.2.6 Graphics Window

3.2.6.1 Viewing Curve Valence

To view your model based on a color-coded curve valence scale, click on the curve valence button on the Display Toolbar. Curve valence refers to the number of surfaces attached to each curve. Curves with exactly two surfaces attached are shown in blue. Curves with exactly one surface are shown in red. Curves with more than two attached surfaces are shown in white.

Figure 26:

This tool is useful for quickly visualizing merged/unmerged topology. Merged curves will usually have a valence > 2, while unmerged curves typically have a valence of 2. Curves with a valence of 1 may indicate a floating surface.

3.2.6.2 Selecting Entities in the GUI

Geometry, mesh entities, boundary conditions, and boundary layers can be selected with the left mouse button directly in the graphics window. Before selecting any entity, however, the correct selection mode must be chosen. This dictates which entity types will be available for selection in the graphics window. The Select Toolbars, which are located above the graphics window by default, are used to change the entity selection modes.

Figure 27: The Selection Toolbar for Geometry and Mesh Entities

Figure 28: The Selection Toolbar for Boundary Conditions

Figures 1 and 2 shows the selection toolbars. Selecting one of the entity selection modes will only permit selection of that particular entity type within the graphics window. These selections will not override a Pick Widget in the command panel. If both volume and surface entities are picked on the select toolbar, a single click will select the surface while a double click will select the volume. More detailed information on selecting and specifying entities can be found in Entity Selection and Filtering .

3.2.6.2.1 Pre-Selection

When the mouse cursor is over an entity type that has been selected from the Pick toolbar, that entity will become highlighted. This is called pre-selection and is used as a graphical guide to show which entity will be picked when the mouse button is clicked. Graphics pre-selection may slow down your graphics speed for large models. You can disable pre-selection from the Tools->Options dialog box.

3.2.6.2.2 Polygon, Sphere, and Box Select

The polygon/box/sphere selection feature allows you to select entities by drawing a box, sphere or polygon on the screen. To draw a box or sphere on the screen press and hold the <CTRL> button* while clicking and dragging the left mouse button. Release the left mouse to complete the box or sphere select. To create a polygon selection, press and hold the <CTRL>* button while clicking and dragging the left mouse button. Click the left mouse button to create another side for the polygon. Press either of the other buttons to close the polygon and complete the selection. Only entities that are in active selection mode will be selected. To change between the polygon or box method, press the Toggle Between Polygon/Box/Sphere Select button on the Select Toolbar. Clicking the Toggle Selected Enclosed/Extended button will toggle between Enclosed Selection and Extended Selection. Enclosed selection will only select entities that are fully enclosed within the bounding box or polygon. Extended selection will select entities that are either fully OR partially enclosed within the bounding box. Toggling the the Select X-Ray will select entities that are hidden behind other entities. X-ray selection will only apply to smoothshade and hiddenline graphics modes. *Note: For Mac computers use the command (or apple) button for polygon or box select.

3.2.6.3 Key Press Commands for the GUI

Several commands have a key press shortcut. These commands will be executed with respect to the currently selected entities; see the following table:

Shortcut Key

Command

l

List information about the current entity to the output window.

i

Toggle the visibility of the selected entity.

e

Echo entity id to command line

TAB

Select the next entity.

SHIFT-TAB

Select the previous entity.

0

Toggle picking of vertices.

1

Toggle picking of curves.

2

Toggle picking of surfaces.

3

Toggle picking of volumes.

4

Toggle picking of groups.

SHIFT-0

Toggle picking of mesh nodes.

SHIFT-1

Toggle picking of mesh edges.

SHIFT-2

Toggle picking of mesh faces.

SHIFT-3

Toggle picking of mesh hexes.

F5

Refresh graphics window.

SHIFT-S

Activate/inactivate graphics clipping plane.

3.2.6.4 Right Click Commands for the GUI Graphics Window

Clicking the Right mouse button in the graphics window will bring up a menu. One of two menus will appear, depending on whether an entity is currently selected.

3.2.6.4.1 With Entity Selected

When an entity is selected, the options available will depend upon the type of entity selected. The following describes the menu options and when they are available.

3.2.6.4.1.1 Entity Selections

Menu Option

Description

Entity Type(s)

Select Other...

Brings up a dialog with alternate entity selections

All

Select Similar Volume

Selects other volumes with the same geometric volume and number of surfaces

Volumes

Select Similar Surface

Selects other surfaces with the same area and number of curves

Surfaces

Select Blend Chain

Selects other surfaces in the same blend chain that have the same radius of curvature

Blend surfaces

Select Cavity

Selects other surfaces in the same cavity collection. Surfaces bounded by curves where the external angle is greater than 180 degrees.

Cavity surfaces

Select Similar Curves

Selects other curves with the same length

Curves

Pick Extended...

Brings up dialog for extended selection. Related entites can be selected using custom criteria defined from a python script.

Surfaces

3.2.6.4.1.2 Entity Visualization

Menu Option

Description

Entity Type(s)

Zoom To

Zoom to the selected entity

All

Rotate About

Center of rotation is changed to the centroid of the selected entity(s)

All

Locate

Text label with line pointing to entity is displayed

All

Draw

Clears the graphics window and draws the selected entity(s)

All

Draw Elements

Brings up a secondary menu with options to Draw specific 3D mesh entity types (without geometry).

Meshed Volumes

Draw Normal

Displays an arrow from the center of the selected surface in the direction of its normal. Also colors surface indicating orientation.

Geometry Entities

Draw With Neighbors

Clears the graphics window and displays the selected entity(s) along with entities sharing a common vertex

Geometry Entities

Isolate

Turn off visibility for all entities except the selected entity(s)

Geometry Entities

Visibility Off

Turn off the visibility of the selected entity(s)

Geometry Entities

3.2.6.4.1.3 Entity Operations

Menu Option

Description

Entity Type(s)

Add to Group/BC

Opens a dialog box for adding the selected entity to an existing boundary condition or group

All

Remove from Group/BC

Opens a dialog box for removing the selected entity from an existing boundary condition or group

All

Mesh

Mesh the selected entities using the current meshing scheme and size settings

Unmeshed Geometry Entities

Delete Mesh

Deletes the mesh from the selected entities using the "propagate" option. (Deletes mesh entities on lower order entities.)

Meshed Geometry Entities

Show Quality

Displays the mesh quality of the selected entities to the output window.

Meshed Geometry Entities

Measure

When a single entity is selected, displays to the output window the geometric length, area or volume. When two entities are selected, displays the closest distance between the entities.

Geometry Entities

List Information

Show a menu with additional options for listing information about the selected entities. List Basic Info: Lists connectivity and associated lower order entities. Geometry: Basic info plus additional geometric information such as centroid, bounding box, surface area etc. List Mesh Info: Basic info plus additional information about the associated mesh.

All

Save Selection As...

Brings up a File Browser to save the currently selected entities as a cub file.

Geometry Entities

Delete

Deletes the selected geometry entities

Free Geometry Entities

Remove

Removes a surface using the remove surface command.

Surfaces in Volumes

3.2.6.4.2 Without Entity Selected

Menu Option

Description

Entity Type(s)

Refresh Display

Clears temporary graphics a refreshes display of current geometry and mesh.

All

Draw Mesh

Displays any existing mesh entities without geometry.

Meshed Entities and Free Mesh

Reset Zoom

Reset graphics viewing options to original settings.

All

All Visible

Reset visibility status to ON for all entities and display.

All

Display Options...

Opens the Display Options Dialog to set graphics window characteristics such as background color, lighting, triad options etc.

All

3.2.6.5 View Navigation in the GUI

There are two different default paradigms for view navigation: Cubit command line and Cubit GUI. The user is allowed to customize the mouse settings as desired. Mouse settings in the GUI are modified by accessing the Tools pull-down menu, then select Options. The Mouse Settings dialog is shown below (See Mouse-Based Navigation for the command line version).

Figure 29: Mouse Settings Dialog

3.2.6.5.1 Rotations

Where the cursor is in the graphics window will dictate how the view will be rotated. If the cursor is outside of an imaginary circle, shown in Figure 30, the view will be rotated in 2d, around an axis normal to the screen. If it is inside the circle, as in Figure 31, the rotations will be in 3d, about the current view spin center. The spin center can be changed to any x-y-z location. The most common way is by zooming to an entity, which changes the spin center to the centroid of that entity. The "view at" command will change the spin center without zooming:

view at vertex 3

Figure 30: With the mouse pointer outside the circle the view is rotated about an axis normal to the screen

Figure 31: With the mouse pointer inside the circle the view is rotated about the current spin center

3.2.6.5.2 Zooming

To zoom, press the appropriate buttons or keys and move the cursor vertically, as shown in Figure 32. The wheel on a wheel mouse will also zoom.

Figure 32: Move the mouse pointer vertically to zoom in and out

3.2.6.5.3 Panning

To pan, press the appropriate buttons or keys and move the cursor horizontally or vertically, as shown in Figure 33.

Figure 33: Move the mouse pointer horizontally or vertically to pan the view

3.2.7 Tree View